当前位置:首页 > Apache

APACHE如何里一个站点绑定多个域名?用ServerAlias servername

canca3年前 (2023-07-11)Apache1493

APACHE2如何里一个站点绑定多个域名?用ServerAlias

以前很笨,要使多个域名指向同一站点总是这样写:

<VirtualHost *:80>
ServerAdmin i@kuigg.com
DocumentRoot /www/kuigg.com
ServerName kuigg.com
</VirtualHost>
<VirtualHost *:80>
ServerAdmin i@kuigg.com
DocumentRoot /www/kuigg.com
ServerName www.kuigg.com
</VirtualHost>
<VirtualHost *:80>
ServerAdmin i@kuigg.com
DocumentRoot /www/kuigg.com
ServerName abc.kuigg.com
</VirtualHost>

这样一来就等于绑了多少域名就开了多少虚拟主机…………


后来看了看书,发现有个叫”ServerAlias“的东西可以用

其实可以这样:

<VirtualHost *:80>
ServerAdmin i@kuigg.com
DocumentRoot /www/kuigg.com
ServerName kuigg.com
ServerAlias  www.kuigg.com  abc.kuigg.com
</VirtualHost>

要绑多少个域名都可以写在 ServerAlias   后面,用空格隔开即可

apache AH01630: client denied by server configuration错误解决方法

出现这个错误的原因是,apache2.4 与 apache2.2 的虚拟主机配置写法不同导致。

apache2.2的写法:

<VirtualHost *:80>  
ServerName fdipzone.demo.com  
DocumentRoot "/home/fdipzone/sites/www"  
DirectoryIndex index.html index.php  
  <Directory "/home/fdipzone/sites/www">  
    Options -Indexes +FollowSymlinks  
    AllowOverride All  
    Order deny,allow  
    Allow from all  
  </Directory>  
</VirtualHost>

如果在2.4中使用以上写法就会有apache AH01630: client denied by server configuration错误。

解决方法,apache2.4中

Order deny,allow  
Allow from all  
Allow from host ip  
 
Require all granted  
Require host ip

修改后的配置如下:

<VirtualHost *:80>  
 ServerName fdipzone.demo.com  
 DocumentRoot "/home/fdipzone/sites/www"  
 DirectoryIndex index.html index.php  
  
 <Directory "/home/fdipzone/sites/www">  
  Options -Indexes +FollowSymlinks  
  AllowOverride All  
  Require all granted  
 </Directory>  
</VirtualHost>

扫描二维码推送至手机访问。

版权声明:本文由Ant.Master's Blog发布,如需转载请注明出处。

本文链接:https://iant.work/post/850.html

分享给朋友:

“APACHE如何里一个站点绑定多个域名?用ServerAlias servername” 的相关文章

AppServ 2.5.9 中集成的 各个软件的版本

AppServ是PHP网页架站工具组合包,泰国的作者将一些网路上免费的架站资源重新包装成单一的安装程序,以方便初学者快速完成架站,AppServ 所包含的软件有:Apache、Apache Monitor、PHP、MySQL、PHP-Nuke、phpMyAdmin。 AppServ 2.5.9 Ap…

Apache整合IIS通用80端口

第一步:修改httpd.conf文件,启用proxy模块             将文件中的LoadModule proxy_module modules/mod_proxy.so…

windows下apache与tomcat整合

jdk1.5.0_04http://java.sun.com/javase/downloads/index_jdk5.jsp在环境变量里面JAVA_HOME=C:\jdk1.5.0_04 tomcat6http://apache.etoak.com/tomcat/tomcat-6/v6.0.18/s…

apache+JK+tomcat负载均衡配置(windows)

apache+JK+tomcat负载均衡配置(windows)

本文主要是记录windows下apache+JK+tomcat负载均衡的配置过程,方便自己以后备用,也希望能给刚接触的xd提供参考。 实验环境的系统已经安装好了apache2.2.17,安装路径D:\Program Files\Apache2.2\  apache http server的…

Apache Tomcat Jk 多虚拟主机配置方法

准备工作: 1.Apache Server 2.2 2.mod_jk.so 3.Tomcat 7 步骤: 1.Copy mod_jk.so to Apache 2.2/modules/ 2.modify Apache 2.2/config/httpd.conf Add: # module mod_j…

授权Apache2 + PHP读写目录权限

摘要:您需要将目录的所有者设置为PHP使用的用户(Web服务器用户)。步骤1:确定PHP用户…

发表评论

访客

◎欢迎参与讨论,请在这里发表您的看法和观点。